PDA

View Full Version : Broken Search Function



webmaster
07-18-2007, 10:51 PM
Sorry about the broken search, I have checked every single file in the system, and actually re-installed the forum software to ensure that all files were properly updated.

I've come to the conclusion that there is something in the server configuration that is funky, and am currently having a discussion with my hosting company, who keeps telling me that our forum isn't compatible with FastCGI (which is funny, because it worked just *fine* on the old server *also* running FastCGI).

Anyway, I've been pretty much working continuously on this, and will hopefully have it cleared up soon.

Sorry for the inconvenience, folks.

JephSullivan
07-19-2007, 12:23 PM
I just learned a new Google trick that may come in handy while the search is down. If you type "site:www.GotMead.com" into Google, it will search only GotMead for results. For example, say you wanted to search for the term "demijohn" on GotMead you would type:

www.gotmead.com+demijohn&spell=1]site:www.GotMead.com (http://www.google.com/search?hl=en&sa=X&oi=spell&resnum=0&ct=result&cd=1&q=site:[url) demijohn[/url]

The drawback is that recent posts are unlikely to turn up in these searches, since Google only examines GotMead for new content every so often.

webmaster
07-19-2007, 08:21 PM
OK, search is now working. Sorry about that, it turns out that since my hosting company doesn't have Pspell installed, it causes spellcheck to fail, and also search. Disable spellcheck, and search is back. Weird.

Anyway, I've a request into hosting to see if they'll give us the spellcheck software.

Vicky - off to do some customer work