PDA

View Full Version : Sulphur smell



Mazer828
10-18-2015, 05:21 PM
Ok this is the first time I've had this happen, and I've been mazing for years. But this is also the first time for two other things I tried for the first time with these batches so I'm hoping there's a correlation.

I made two 1-gallon experimental traditional Mead batches, using new honeys I discovered. Both batches I made using this identical method, just different honeys:

Red star Pasteur red yeast (never used before), rehydrated for 30 min in 1/4 cup room temp water, with 1/4 tsp yeast nutrient blend (never used this rehydration method before).

Honey mixed with room temp tap water (well water) to exactly 1.100 SG. Transferred from mixing bucket into 1 gal carboys, shook to aerate, and added yeast and one additional tsp yeast nutrient.

Temp at pitching was about 70, but grew overnight as the wood stove was stoked to take the chill out during the night. The upper range listed for that yeast is 86. Approximately 10 hours later fermentation had begun and everything looked and smelled fine. However about four hours after that, BOTH batches exhibited a pretty strong smell of sulphur. Temperature seems to still be hovering around 76-78.

So did I screw up with my yeast selection or my rehydration method? Next step might be just repeat the experiment with a known yeast.

Thanks for any thoughts out there!

Sent from my SM-N900V using Tapatalk

Squatchy
10-18-2015, 06:37 PM
So you hurt your yeast very badly when you rehydrated. Don't rehydrate with anything other than water, (unless you use Goferm). Use 104 degree water and pitch within 30 minutes. AAlso you don't want more than a 10 degree difference between yur slurry temp and the must temp.. So, if your slurry is warm and your must is cool,,,, add a small amount of must to the slurry every 5 minutes untill the slurry is as cool as the must is. More than ten degrees difference causes temperature shock. And rehydrtating with nutient hurts the yeast very badly.

Mazer828
10-18-2015, 09:04 PM
Good to know. Asked a local brewer (semi professional) and LHBS owner whether you could use nutrient in place of GoFerm and that's what he recommended. 1/4 tsp to 1/4 cup water for one pack yeast.

Anyway, I won't do that again. Anything to do about it now? The sulphur odor is starting to fade now. I'm degassing every few hours.

Sent from my SM-N900V using Tapatalk

mannye
10-19-2015, 06:48 AM
If it persists, running the must through a copper coil is helpful. There are several ways to use copper.. Search "using copper to remove sulphur smell" on google and you will find many different methods. Someone here mentioned a small length of copper tube placed in the bucket for a few days. Also those pure copper scrubbers work.


Sent from my TARDIS at the restaurant at the end of the universe while eating Phil.

Squatchy
10-19-2015, 08:53 AM
I use the copper piece of pipe and it worked great

mannye
10-19-2015, 10:30 AM
Dont forget that often the smell is an indicator of malnourished yeast. Try adding nutrients and see if the odor goes away.


Sent from my TARDIS at the restaurant at the end of the universe while eating Phil.