PDA

View Full Version : Sulphur Smell After Fruit Addition



Mazer828
10-31-2015, 03:25 PM
I have a blackberry mel I'm making, that I started in primary with white clover honey, at about 1.078 OG, no boil, and fermented at about 70F with a mix of EC-1118 and 71B-1122 yeasts. I started the ferment with 5 tsp of yeast nutrient blend at pitch. When it reached 1.020, I racked into a clean bucket with 8 lbs of mashed, previously frozen blackberries.

I didn't add any more nutrient, figuring the blackberries would provide plenty. However, now after about four days on the fruit, the SG is down to 1.000, fermentation is slowed, but there is some sulphur being produced. Not eggy or rubbery, but definitely sulphur.

This morning I racked it off the fruit. Temp is still right around 68-70F. My goal in racking it now was to help halt the ferment, and degas it, which I did more of in the carboy by stirring briskly with a clean spoon handle. And I added 2 cups of honey with the thought of sweetening a little and getting the yeast to produce a tiny bit more gas to help flush out the sulphur.

Thoughts? Comments? Suggestions?

ScottBehrens
10-31-2015, 04:49 PM
Did you pick your berries or store bought?

loveofrose
10-31-2015, 04:57 PM
Sulphur smells are generally an indication of yeast stressed from lack of free nitrogen. Since you are at the later part of fermentation, DAP is not an option. I suggest a boiled bread yeast or a Fermaid O addition.


Better brewing through science!

See my brewing site at www.denardbrewing.com

See my Current Mead Making Techniques article here:
http://www.homebrewtalk.com/current-mead-making-techniques.html

Mazer828
10-31-2015, 05:04 PM
I can definitely do the boiled bread yeast. And @kernel krush, frozen store bought.

Mazer828
11-01-2015, 11:48 AM
I added one tbsp bread yeast boiled in 1/2 cup water and cooled, last night. This morning, very light fermentation is evident, and no off aromas detectable at the moment!