PDA

View Full Version : First Batch - Is fermentation stalled?



Stevo
11-05-2016, 04:42 PM
Hey all,

First off, I'll list my recepie and ingredients used.

- 15lbs (7kg) likely alfalpha honey
- 5G spring water (less volume taken by honey)
- 1/2 tsp yeast nutrient DAP (as per directions on package)
- 1 tsp energizer (directions call for 1.25mL/4.5L)
- 2 x Lalvin EC 1118 yeast rehydrated as per package directions

I mixed up the must with energizer and nutrient prior to pitching yeast as per directions. Must has been fermenting since October 16th at a consistent 60degF. I didn't have a hydrometer at the time however at this point it is reading 1.052 according to the percentage on the hydrometer. This is sitting at roughly 7%. I was thinking by now it would have been considerably higher (12-13% mark).

Has the fermentation process become stuck or am I just being impatient?

Squatchy
11-05-2016, 05:32 PM
That yeast would have easily gone dry if everything is alright.

Stevo
11-05-2016, 06:44 PM
That yeast would have easily gone dry if everything is alright.

Sorry, not quite understanding by "gone dry". Not up to speed on the terms yet haha. As mentioned, this is first batch.

jeffvenuti
11-05-2016, 07:03 PM
Sorry, not quite understanding by "gone dry". Not up to speed on the terms yet haha. As mentioned, this is first batch.
Stevo, monitor the specific gravity daily over the next several days and then report back here with the readings. It's hard to tell too much from a single reading.

Jeff

Sent from my SAMSUNG-SM-G900A using Tapatalk

Squatchy
11-05-2016, 07:11 PM
Gone dry means that yeast should be able to eat all of the sugar in your batch leaving you with zero sweetness left behind. It will taste very dry.

Stevo
11-05-2016, 07:15 PM
Thanks gentlemen for the quick responses.

I'll keep it going in the primary for a few days yet and get back to you with the readings.

Cheers.

dwilson1
11-05-2016, 09:22 PM
Hi all
Just join up and please bare with me as I'm new to forums and don' t know if I've started in the right place. I live down-under in Oz and I've just put my first batch down.
It contains the following,
- 7 kg aldi honey.
- 23 Lt filtered tank water.
- 1 tsp wine nutrient (did not read instructions ).
- 1 tsp yest energiser (came with no instructions ).
Mixed very well with drill and paint mixer, the hydrometer read around 1.140 and abv was 16 - 18 %, yeast used was CY - 17. temp 24 - 26 c.
Bubbling away like a kettle on the boil, 24 hrs after mixing.
I,m trying to make a semi-dry to dry mead with a little spice for my female co-workers.
Any advice or help would go down well and I wait for your response.

darigoni
11-05-2016, 09:42 PM
The gentleman who started this conversation (thread), is still waiting for answers to his questions. It would be better if you started your own thread, where patrons can focus on your questions.

dwilson1
11-05-2016, 09:57 PM
Thank you, How do I do that?

darigoni
11-05-2016, 10:02 PM
Thank you, How do I do that?

Go here: http://www.gotmead.com/forum/forumdisplay.php/136-Mead-NewBees-Post-your-Questions-Here

And create your own post/question.

dwilson1
11-05-2016, 10:11 PM
Thank you, for your directions

Stevo
11-07-2016, 11:29 PM
So, as odd as this sounds, my numbers appear to be going in the other direction. SG now reads 1.046

Should I be concerned?

jeffvenuti
11-08-2016, 01:45 AM
So, as odd as this sounds, my numbers appear to be going in the other direction. SG now reads 1.046

Should I be concerned?

Stevo,

SG readings go down during fermentation. Do a little research on this.

From your recipe you likely started with a SG near 1.114. A couple days ago you were at 1.052. Today you're at 1.046. If you're taking hydrometer readings correcly then your mead is fermenting. And as Squatchy said, this yeast (EC-1118) should take you down to 1.000. Just be patient. Go brew something else and forget about this one.

By the way, a hydrometer doesn't tell you ABV. It can only tell you potential ABV. So as your SG drops, so does the hydrometer ABV reading. It doesn't know anything about where you started. Its just a dumb piece of glass.

Jeff

So, as odd as this sounds, my numbers appear to be going in the other direction. SG now reads 1.046

Should I be concerned?


Sent from my SAMSUNG-SM-G900A using Tapatalk

Stevo
11-08-2016, 01:43 PM
Haha okay thanks (I did a facepalm there). I haven't seen anything on the hydrometer use, just the numbers on the side. Figured it went the other way.

I was afraid I was going to wind up with something close to American lite beer