First of all, I cannot thank you enough for this wonderful website you've put together. I have probably looked on here an average of three times a day for the past three months and read and read and read and loved every minute of it. I am hoping to become a patron in the near future, but am holding off with grad school on the horizon and a lot of financial question marks because of that.

The one issue I just had was when, while using the search tool, I tried to search for "Joe's" (no quotes) and it claimed that there were no results. I also tried an advanced search, searching just the thread titles and it also said no results, even though I got the whole idea to search Joe's from this thread's title.

As you may have guessed, I was looking for recipes by Joe Mattioli and have since found a more effective way to do so, but I'm assuming the problem is with the apostrophe since "Joes" did give me results. I don't know how easy/necessary it is to fix this, but I thought I'd just let you know.

Thanks again for a great site.