View Full Version : A (minor) search concern

12-07-2009, 09:03 PM
First of all, I cannot thank you enough for this wonderful website you've put together. I have probably looked on here an average of three times a day for the past three months and read and read and read and loved every minute of it. I am hoping to become a patron in the near future, but am holding off with grad school on the horizon and a lot of financial question marks because of that.

The one issue I just had was when, while using the search tool, I tried to search for "Joe's" (no quotes) and it claimed that there were no results. I also tried an advanced search, searching just the thread titles and it also said no results, even though I got the whole idea to search Joe's from this thread's title. (http://www.gotmead.com/forum/showthread.php?t=15013)

As you may have guessed, I was looking for recipes by Joe Mattioli and have since found a more effective way to do so, but I'm assuming the problem is with the apostrophe since "Joes" did give me results. I don't know how easy/necessary it is to fix this, but I thought I'd just let you know.

Thanks again for a great site.

Big Mac
12-07-2009, 09:38 PM
Perhaps it is the length of the search term. An experienced member suggested that one search "sur lie," but both terms are too short to search.

12-07-2009, 10:11 PM
I thought that too at first, but usually it notifies me when I'm searching for a term that is too short.

That being said, I just searched "wouldn't" and got plenty of results. It tells me that Joes works and it tells me that Joe is too short. But when I search Joe's it just tells me that there are no results. Maybe it's just an isolated thing then.

Medsen Fey
12-07-2009, 10:21 PM
I've encounter the same problem. It seems to occur with the apostrophe in some cases as you have identified. Leave the apostrophe out, and it works. Vicky and Pete are aware of the issue and I believe that are looking into it, but quite frankly because it is a minor thing I think it is way down on their to do list.

12-07-2009, 11:28 PM
I have been doing searches for Sur and Lie together. as in "Sur Lie" that hasn't been giving any results either.

But now the question is. I shouldn't have been searching them together?


12-07-2009, 11:39 PM
Man, sur lie does kind of defeat the search thing, bummer. You could try "lees", but you'll get a lot of mishits. Hmm. Oh! try "battonage".

12-08-2009, 08:54 AM
Thanks, Akueck! I had been having the same problem trying to search "Sur Lie". Searching "Battonage" came up with a lot of good results.

I'm constantly impressed with the number of helpful people on this forum. Once the holiday insanity is over I'm definitely becoming a patron.

12-08-2009, 01:10 PM
This is a shortcoming in the search engine, and we're at the mercy of the developers on this one unfortunately.



12-08-2009, 10:57 PM
I doubt very much anybody would blame anyone for one small glitch in the system. At least, I know, I don't.

Thanks though for battonage


12-17-2009, 11:26 PM
sur lie (http://www.bing.com/search?q=sur+lie+site%3Agotmead.com&form=QBLH&qs=n)

How to perform your own unsupported queries on gotmead.com:

1. Go to http://www.bing.com
2. In the search box, enter site:gotmead.com along with the rest of the search terms.
3. Success!

This works great for short terms, and has the added bonus of searching the entire gotmead.com site, not just the forums.


12-17-2009, 11:41 PM
That's actually good to know, I have a lot of situation's where I could use being able to search shorter terms.

12-18-2009, 09:32 AM
If you want to search just the forums you can enter site:gotmead.com/forum

This also works with Google and probably most other major search engines if you're like me and have a hard time bringing yourself to use bing. :)

12-20-2009, 05:17 PM
Sadly, search functions in forum software tend to be rather poorly done. This is the case with every forum package I've researched in the last several years.

We are aware of the apostrophe thing, and that is an issue in mySQL, where an apostrophe indicates the end of a field. It wants to see a /'/ inside a field to indicate the apostrophe, escaping it so it can be read. However, this doesn't work great in the search.

We may at some point introduce a Google search on the site, I'll put it on my list of things to research. That list is very long, and I'm doing this in my spare time from working for a startup company, so it goes slowly. I'll not use Bing, I've had too many issues with it, and gotten way too many negative reports on it.

Glad you like the site! I'll keep working to make it better and more informative.